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New Installation (Microsoft Access) 
  

Upgrading? If you are upgrading or installing a free update, do not proceed, see the Upgrading 

Instructions. 

 

Download & Extract the PDshop Zip file 
Download the zip file that contains the PDshop scripts/files, ex."pdshop_classic.zip".  Save it to your 

computer, or web server. Using your Unzip program, locate the file you just saved, and extract all files 

and folders contained within it to your computer.  

 

Determine Database Location 
PDshop is a database driven application.  Unlike HTML pages, which are static, .asp scripts are dynamic 

and display text and other data that is stored in a database.   

 

PDshop comes with a preconfigured Microsoft Access database (compatible with MSAccess 

2000/2003/XP).  The database file, usually name "PDshop.mdb", is located in the "data" folder of the zip 

file.  To install PDshop, you will need to upload this database file to your web server (as well as the other 

scripts).  It is strongly recommended that you rename the data directory, or choose a secure/private 

folder.  Most web hosts provide a special database folder on your web server, or allow you to create your 

own.  This folder should have special security (a.k.a. "permissions") so that the database file cannot be 

accessed or downloaded by unauthorized users. 

 

Editing your 'setup.asp' file 
The "setup.asp" file is the configuration file used to define a series of important variables, shared by all of 

the PDshop scripts.  Most importantly, this file defines your database location and how to connect to it 

(i.e. what database driver to use, and where the database is).   

 

Locate the "setup.asp" file in the "includes" directory (it's one of  the files you unzipped earlier).  Using 

Microsoft's "Notepad", usually found under "Program Files>Accessories", you can open this file and make 

changes.  Since every web server is configured differently, you will likely need to modify the database 

"connection string" found in this file.  The setup file contains several sample connection strings that you 

may use.  See the file's internal comments.  You will need to know the location (DSN or Path) of your 

database, and which driver is available for you to use.  Modify the "dbconn" or "db.open" variable as 

needed.  Be sure to only use one (1) connection string. 

 

Unsure how to edit this file? 

If you are using a web hosting service, your web host should provide some basic "path" information or 

sample connection strings, see their support pages for examples.  If you are unsure how to edit the 

"setup.asp" file, PageDown Technology does offer an installation service.  Let our team configure, and 

upload PDshop to your web server (see our website for more details, 

http://www.pagedowntech.com/shop/)  

 

Encryption Code Notes  

The encryption code variable, usually named "cryptpass", is the "password" used to encrypt and decrypt 

sensitive data that is stored in the PDshop database. If you do not wish to use the default encryption 

code, you must change it before you begin using the online store, it cannot be changed once passwords, 

or credit card data has been stored in the database. The cryptpass code must be kept short, less than 10 

characters, or the performance of your server may be compromised.  If you choose to edit the PDshop 

database directly (using your own software instead of PDAdmin), do not attempt to edit any database 

fields that are encrypted.  If you edit passwords or credit card numbers using your own program, you may 
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corrupt the data in the encrypted fields, PDshop will no longer be able to read this data.  Furthermore, you 

may get locked out of PDAdmin if you edit Administrative passwords). 

 

Uploading the Database 
Using your FTP software, follow your web host's instructions for logging into your server/FTP server.  Once 

logged in, you should be able to see any existing folders or files already on your server.   

 

Locate a suitable location on your server for the database file ("PDshop.mdb").  It is recommended that 

you create or use a folder that is not located in your "web root".  Your database file should be located in a 

folder that has special security (a.k.a. "permissions"), configured in such a way to prevent unauthorized 

access.   Upload the database file to your web server. 

 

Uploading the ASP scripts 
Next, you will need to upload all of the remaining PDshop scripts/files.  Using your FTP software, navigate 

to your "web root", the primary folder on the server where your html/asp files are loaded. For example, 

many web hosts name the web root folder "wwwroot".  Upload all of the PDshop files and folders to your 

server, be sure to keep the PDshop files in their original folders.  After uploading, your directory structure 

should look something like this: 

/wwwroot/admin/ 

/wwwroot/includes/ 

/wwwroot/shop/ 

 

Or, if your FTP root and WWW root are the same: 

 

/admin/ 

/includes/ 

/shop/ 

 

Folder Notes  

As a general security precaution, it is recommended that you rename the 'admin' and 'data' folders, to 

help protect against unauthorized access.   

 

Setting Permissions 
Using your web host's control panel, you will need to set or check the "permissions" (security settings) on 

your web server.  If your web host does not provide these setting, you may need to contact them for 

these important security changes (this is a common request, your web host should have no problem with 

adjusting these settings for you). 

 

Your database file must have at least "Write" permission, so that the server allows PDshop to save/update 

the database.  

Note  

Always consult with your web host or server administrator before making any security related changes.   

 

Testing PDshop 
Using your web browser, type http://www.yourdomain.com/shop/ to test PDshop.  The PDshop database 

includes a sample/test category and item.  Upon reaching the storefront, you should see the test item.  

Click the "Buy Now" button while viewing this item to add it to your shopping cart.  If the item is added to 

your cart, than you have successfully installed PDshop.  You are ready to Proceed to the web based 

Administrator, PDAdmin.  Using Internet Explorer 5 or above, go to 

http://www.yourdomainname.com/admin/ to continue setting up your store.  Click on "Help" while in 

PDAdmin for questions about PDAdmin. 
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If you receive an "Internal Server Error", or are unable to see the storefront while trying to access the 

store or PDAdmin, see Troubleshooting. 

 

For information relating to security, see “Best Practices”. 
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New Installation (Microsoft SQL Server) 
  

Upgrading? If you are upgrading or installing a free update, do not proceed, see the Upgrading 

Instructions. 

 

Download & Extract the PDshop Zip file 
Download the zip file that contains the PDshop scripts/files, ex."pdshop_classic.zip".  Save it to your 

computer, or web server. Using your Unzip program, locate the file you just saved, and extract all files 

and folders contained within it to your computer.  

 

Create blank Database 
PDshop is a database driven application.  Unlike HTML pages, which are static, .asp scripts are dynamic 

and display text and other data that is stored in a database.   

 

The first step is to create a new, completely blank, MSSQL database.  Contact your web host or server 

administrator for this procedure.  Creating a blank database can be done using your SQL "Enterprise 

Manager", or in many cases, your web hosts control panel. 

 

Editing your 'setup.asp' file 
The "setup.asp" file is the configuration file used to define a series of important variables, shared by all of 

the PDshop scripts.  Most importantly, this file defines your database location and how to connect to it 

(i.e. what database driver to use, and where the database is).   

 

Locate the "setup.asp" file in the "includes" directory (it's one of the files you unzipped earlier).  Using 

Microsoft's "Notepad", usually found under "Program Files>Accessories", you can open this file and make 

changes.  Since every web server is configured differently, you will likely need to modify the database 

"connection string" found in this file.  The setup file contains several sample connection strings that you 

may use.  See the file's internal comments.  You will need to know the location (DSN, Server Name, or IP 

Address) of your database, and which driver is available for you to use.  Modify the "dbconn" variable as 

needed.  Be sure to only use one (1) connection string.  For MSSQL databases, you must uncomment the 

dbsql="Y" variable (by removing the apostrophe).  This variable tells the rest of PDshop's scripts that you 

are using an MSSQL server, which handles some formatting differently. 

 

Unsure how to edit this file 

If you are using a web hosting service, your web host should provide some basic "path" information or 

sample connection strings, see their support pages for examples.  If you are unsure how to edit the 

"setup.asp" file, PageDown Technology does offer an installation service.  Let our team configure, and 

upload PDshop to your web server (see our website for more details, 

http://www.pagedowntech.com/shop/)  

 

Encryption Code Notes 

The encryption code variable, usually named "cryptpass", is the "password" used to encrypt and decrypt 

sensitive data that is stored in the PDshop database. If you do not wish to use the default encryption 

code, you must change it before you begin using the online store, it cannot be changed once passwords, 

or credit card data has been stored in the database. The cryptpass code must be kept short, less than 10 

characters, or the performance of your server may be compromised.  If you choose to edit the PDshop 

database directly (using your own software instead of PDAdmin), do not attempt to edit any database 

fields that are encrypted.  If you edit passwords or credit card numbers using your own program, you may 

corrupt the data in the encrypted fields, PDshop will no longer be able to read this data.  Furthermore, you 

may get locked out of PDAdmin if you edit Administrative passwords). 
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Uploading the ASP scripts 
Next, you will need to upload all of the PDshop scripts/files (except for files in the "data" directory, which 

are not relevant to MSSQL).  Using your FTP software, navigate to your "web root", the primary folder on 

the server where your html/asp files are loaded. For example, many web hosts name the web root folder 

"wwwroot".  Upload all of the PDshop files and folders to your server, be sure to keep the PDshop files in 

their original folders.  After uploading, your directory structure should look something like this: 

/wwwroot/admin/ 

/wwwroot/includes/ 

/wwwroot/shop/ 

 

Or, if your FTP root and WWW root are the same: 

 

/admin/ 

/includes/ 

/shop/ 

 

Folder Notes 

As a general security precaution, it is recommended that you rename the 'admin' and 'data' folders, to 

help protect against unauthorized access.   

 

Formatting the MSSQL Database 
Using your web browser, the next step is to run the database format procedure, which will add the 

necessary tables, columns (fields), and default data to your new database.  Using your web browser, 

navigate to the "dbsetup.asp" page in your "admin" directory on your server.  For example,  

http://www.yourdomainname.com/admin/dbsetup.asp.   

 

Next, see the "Format Database" heading and click the "Begin Format" button.  This procedure will not 

create the database, it will only add the tables, columns (fields), and default data.  Make sure you have 

created a new/blank database first (see above). 

  

Testing PDshop 
Using your web browser, type http://www.yourdomain.com/shop/ to test PDshop.  The PDshop database 

includes a sample/test category and item.  Upon reaching the storefront, you should see the test item.  

Click the "Buy Now" button while viewing this item to add it to your shopping cart.  If the item is added to 

your cart, than you have successfully installed PDshop.  You are ready to Proceed to the web based 

Administrator, PDAdmin.  Using Internet Explorer 5 or above, go to 

http://www.yourdomainname.com/admin/ to continue setting up your store.  Click on "Help" while in 

PDAdmin for questions about PDAdmin. 

 

If you receive an "Internal Server Error", or are unable to see the storefront while trying to access the 

store or PDAdmin, see Troubleshooting. 

 

For information relating to security, see “Best Practices”. 
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Upgrading or Installing an Update 
  

New Installation? If you are installing PDshop for the first time, do not proceed, see the New Installation 

Instructions. 

 

Backup Existing site 
Before uploading the updated files, you must make a backup of your existing PDshop files and database. 

We recommend downloading the old files to a safe location on your local computer before proceeding. This 

way, if anything unforeseen happens, you can simply re-upload the original files and database. Our free 

technical support does not include data recovery or cover some severe problems encountered by an 

update/upgrade mishap. 

 

Download & Extract the PDshop Zip file 
Download the zip file that contains the PDshop scripts/files, ex."pdshop_classic.zip".  Save it to your 

computer, or web server. Using your Unzip program, locate the file you just saved, and extract all files 

and folders contained within it to your computer.  

 

Editing the 'setup.asp' file 
The "setup.asp" file is the configuration file used to define a series of important variables, shared by all of 

the PDshop scripts.  Most importantly, this file defines your database location and how to connect to it 

(i.e. what database driver to use, and where the database is).   

 

Locate the new "setup.asp" file in the "includes" directory (it's one of the files you unzipped earlier).  

Using Microsoft's "Notepad", usually found under "Program Files>Accessories", you can open this file and 

make changes.  Since every web server is configured differently, you will likely need to modify the 

database "connection string" found in this file.  You can use your old setup.asp file as a guide.  It is 

recommended that you update and use the new setup.asp file, as some variables may have changed since 

your last installation. 

 

Encryption Code ("cryptpass") Notes: If you did not use the default encryption code when you first 

installed PDshop, be sure to modify this variable with your own password (see your old setup.asp file).   

 

Uploading the ASP scripts 
Next, you will need to upload all of the PDshop scripts/files (except for any files in the "data" directory, 

which are for New Installations only).  Using your FTP software, navigate to your "web root", the primary 

folder on the server where your existing .asp files are loaded.  For example, many web hosts name the 

web root folder "wwwroot" or something obvious.  Upload all of the .asp files to your server, placing them 

in the correct folders (for example the "shop" files need to be uploaded to your "shop" folder, "admin" files 

to your admin folder, "includes" to includes, etc).  You will need to overwrite all existing .asp files with the 

same name.   

 

DATABASE WARNING!!! 

Updates & Upgrades include a new, blank Microsoft Access database file, with the same name as your old 

one!   If your current PDshop uses a Microsoft Access database, you must take special precautions.  Do 

NOT upload the blank database (usually named "PDshop.mdb") to your web server. 
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CUSTOM SCRIPT WARNING!!! 

If you made your own script changes, we do not recommend installing any updates or upgrading.  When 

you install PDshop's scripts, you will be required to overwrite all existing scripts with the same name, 

which may undo changes you may have made.   

 

Add-On Notes 

If you have the UPS or USPS Add-on, you will need to re-upload the Add-On scripts after uploading the 

upgrade/update scripts.   

 

Folder Notes 

As a general security precaution, it is recommended that you rename the 'admin' and 'data' folders, to 

help protect against unauthorized access.   

 

Note 

Always consult with your web host or server administrator before making any security related changes.   

 

Upgrading the Database 
Using your web browser, the next step is to run the database format procedure, which will add any new 

tables, columns (fields), and default data to your existing database.   

 

1. Open your browser and go to "yourstore.com/admin/dbsetup.asp". Under procedures you will need to 

run the "Format Database" procedure. This procedure will check your current database, some fields will be 

added to the existing tables, new tables will be added, and all field definitions will be checked and 

corrected if necessary. You cannot undo this process, so you MUST backup your database first! Do not run 

this step repeatedly, only run this once as it uses a large amount of your server resources. 

 

2. (Optional - only run if upgrading from the original PDshop Standard / v2.0) The "Upgrade v2.0 Data" 

procedure will adapt some of your existing v2.0 data to the newer database format. This process 

updates/moves data into some of the new fields and tables, and must be run after step 1. You MUST 

backup your database first before trying to run this procedure! Do not run this script more than once, as it 

may produce duplicate records in your database. 

  

Testing PDshop 
Some of the changes may require you to update, check, or change general settings and configuration. 

After installing, it is recommended that you immediately go through each setup page (including 

items/categories) and look for any new fields. As a general rule you can open the page and click “save”, to 

see if you are missing any required data. 

 

If you receive an "Internal Server Error", or are unable to see the storefront while trying to access the 

store or PDAdmin, see the Troubleshooting Guide.  Most problems are the result of not setting 

permissions, not running the database procedure(s), or not uploading all of the scripts in the download.   

 

 

When installing an upgrade or free update, be sure to follow this guide, step by step. 

 

For more help, see “Troubleshooting”. 

 

For information relating to security, see “Best Practices”. 
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Troubleshooting (Internal Server Errors) 
  

Configure Your Browser 
The first step in troubleshooting is reviewing the error message details.  You will need to use Internet 

Explorer to troubleshoot PDshop setup errors.  Be sure to change the settings on your web browser so 

that you can see the full error message.  Most error messages would include phrases such as ODBC Error, 

VBscript Compilation Error, and may be followed by script line number.  

If you do not see any details, only "Internal Server Error" or "Page Cannot be Displayed", you need to adjust your 
browser settings.   

 

To see the full detail of an error message, do the following:  

In Internet Explorer, click on Tools>Internet Options>Advanced. Under "Browsing", Uncheck the box 

labeled "Show friendly HTTP error messages" and click "Apply" then "Save". 

 

Common Mistakes 
The most common mistakes when upgrading or installing an update are: 

Not uploading all of the .asp scripts in the zip file you downloaded   

You should not mix & match script versions, when uploading be sure to overwrite all scripts on your web 

server with the new ones.  NOTE: If you have the UPS or USPS Add-on, you will need to re-upload the 

Add-On scripts after uploading the upgrade/update scripts. 

 

Not running the “Format Database” procedures 

In most cases you will need to run the "Format Database" procedure (which upgrades your database 

tables & columns) 

 

When installing an upgrade or free update, be sure to follow the Upgrading Installation Guide, step by 

step. 

 

Cannot update. Database or object is read-only 
  

This error usually indicates that you did not set the appropriate permissions on the database, 

"PDshop.mdb". You will need to change the security settings (a.k.a. permissions) on the web server. 

 

Using a hosting service? 

Contact your web hosting service and request that they set your database permissions, or follow the 

instructions they provide for setting permissions.  

 

Running your own server? 

The security account used by the web server IIS service should have at least "Write" permissions on the 

database file (Note: You cannot set the permissions from within IIS, see below). To adjust the file 

permissions, you need to locate the file "PDshop.mdb" by using "My computer". Right click on the file, 

click on "Properties". Next, click on "Security". There are several user/system accounts listed, you'll need 

to modify the permissions for the account that the IIS web service uses (if you don't know, you can 

always add the user "Everyone" and give it "Full Control"). NOTE: You cannot use the IIS console to 

change the file permissions, the Access settings in the IIS console are not the same as "File Permissions". 

The settings in IIS only control what web browsers/internet users have access to (not file security). 

 



 11 

Unable to open registry key 'Temporary (volatile) Jet DSN for process 
 

This messages usually indicate a problem with the database path or DSN (the location you specified in the 

setup.asp file).  You should check your setup.asp file in the “includes” directory, as your connection string 

is likely the problem.  Or, you did not upload the database to the location specified in the setup.asp file.   

 

Data source name not found and no default driver specified Error 
 

This messages usually indicate a problem with the database path or DSN (the location you specified in the 

setup.asp file).  You should check your setup.asp file in the “includes” directory, as your connection string 

is likely the problem.  Or, you did not upload the database to the location specified in the setup.asp file.   

 

Too few parameters. Expected 1.  
 

Messages similar to this usually indicate that you did not run the database "Format" procedure, as 

described in the Installation or Upgrading Instructions.   

 

The Microsoft Jet database engine cannot find the input table or query 'setup'.  
 

Messages similar to this usually indicate that you did not run the database "Format" procedure, as 

described in the Installation or Upgrading Instructions.   

 

The Include file '../includes/setup.asp' cannot contain '..' to indicate the parent 
directory 
 

The above error can occur when PDshop is hosted on a "virtual" server where your web provider has 

disabled "parent paths". You should contact your web provider and request that they "enable parent 

paths". If you are the administrator, or have access to the IIS console, modify the Parent Path setting for 

your virtual web. This setting is located under the "Home Directory" tab, under "Configuration" on the 

"App Options" tab.  

 

Another Alternative solution would be to replace all instances of the "include" command in the .asp scripts 

with "virtual". To do this, you need to edit all .asp files (using Notepad or an HTML editor such as 

Frontpage) that reference the "include" or mappath commands.  

 

Example, replace all instances of:  

#include file="../includes/  

server.mappath("../includes/ 

 

WITH:  

#include virtual="/includes/ 

server.mappath("/includes/ 

 

If you do not plan to upload PDshop to your "web root", you may need to specify the parent directory in 

your paths, ex. "/parentdirectoryname/includes/". 

 

Browser Related Problems 
If you experience problems client side, with your browser, see Browser Troubleshooting. 

 

For additional help, see our Knowledgebase at www.pagedowntech.com/faq. 
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Troubleshooting (Browser Problems) 
  

If you experience problems with your browser while working with PDAdmin or PDshopPro, you may need 

to perform some routine housekeeping tasks as described below.   

Common Problems 
Pop-Up windows do not open. 

HTML / Content Editor does not work correctly. 

JavaScript Errors. 

Shopping cart contents do not appear to save. 

 

Common Causes 
Some of the common client side problems are due to the following: 

 

1. A corrupt browser cache (temporary internet files/cookies). 

2. Internet Explorer Add-Ons are blocking some JavaScript or Iframe functions. 

3. Incorrect Internet Explorer security settings. 

4. 3rd party security, Privacy, Firewall, or other Internet related software. 

5. JavaScript (a.k.a. Active Scripting) is disabled. 

6. Cookies are disabled or being intercepted/blocked by security/privacy software. 

 

Most issues can be resolved by following all of the steps outlined below: 

 

Delete “Cookies” 

Internet Explorer (version 5) 

1. On the Tools menu, click Internet Options, and then click the General tab.  

2. In the Temporary Internet Files section, click Settings.  

3. Click View Files.  
4. On the View menu, click Details.  

5. Click the Internet Address column header, and then find the Internet addresses of the cookie files. 

For example, a cookie Internet address may be named similar to the following name: 

Cookie:username@websitename.com  

6. Click a cookie file, and then press DELETE. If you are prompted to confirm that you want to delete 

the file, click Yes. Repeat this step for each cookie file.  

Internet Explorer (version 6) 

1. On the Tools menu, click Internet Options, and then click the General tab.  

2. In the Temporary Internet Files section, click Delete Cookies, click OK, and then click OK again.  

 

Internet Explorer (version 7) 

1. Open IE, click on Tools 
2. Click on Delete Browsing History 
3. Press the Delete Cookies button. 

 

Delete Temporary Internet Files 

Internet Explorer (version 5) 

1. Open IE and click on Tools 
2. Click on Internet Options 
3. On the General Tab, in the middle of the screen, click on Delete Files 
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4. You may also want to check the box "Delete all offline content" 

5. Click on OK and wait for the hourglass icon to stop after it deletes the temporary internet files 

Internet Explorer (version 6) 

1. Open IE and click on Tools 
2. Click on Internet Options 
3. On the General Tab, in the middle of the screen, click on Delete Files 

4. You may also want to check the box "Delete all offline content" 

5. Click on OK and wait for the hourglass icon to stop after it deletes the temporary internet files 

Internet Explorer (version 7) 

1. Open IE, click on Tools 
2. Click on Delete Browsing History 
3. Press the Delete Files button. 

 

Disable Browser “Add-Ons” 

Internet Explorer (version 5) 

1. Close all instances of IE, click Start, point to Settings, and then click Control Panel.  
2. Double-click Internet Options.  
3. Click the Advanced tab.  
4. Under Browsing, click to clear the Enable third-party browser extensions (requires restart) check 

box.  

5. Restart IE.  

Internet Explorer (version 6) 

1. While IE is open, go to Tools > Internet Options > Programs Tab > Manage Add-ons.  

2. Disable any 3rd party Add-On that may be interfering with normal operation. You may need to 

restart the browser for the changes to take affect. 

Internet Explorer (version 7) 

1. While IE is open, go to Tools > Manage Add-ons.  

2. Disable any 3rd party Add-On that may be interfering with normal operation. You may need to 

restart the browser for the changes to take affect. 

 

Delete browsing “History” 

Internet Explorer (version 5) 

1. Open IE and click on Tools 
2. Click on Internet Options 
3. On the General Tab, in the middle of the screen, click on Clear History 

4. Click OK 

Internet Explorer (version 6) 

1. Open IE and click on Tools 
2. Click on Internet Options 
3. On the General Tab, in the middle of the screen, click on Clear History 

4. Click OK 
 

Internet Explorer (version 7) 

1. Open IE, click on Tools 
2. Click on Delete Browsing History 
3. Press the Delete History button. 
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Reset all Internet Explorer Security & Privacy Settings 
Reset ALL Security & Privacy settings to their original settings; use the set to "defaults" buttons where 

possible.  Most browser related problems can be resolved by returning your settings to their defaults. 

 

Disable 3rd party software 
Turn off script filters/blocking, Pop-UP/Virus/Firewall software, or any other internet related software. 

Norton's Script Blocking Service, Norton's Internet Security software, and Zone Labs Zone Alarm Security 

software, are among many, that if not configured correctly, can interfere with or block some basic 

JavaScript & "Iframe" functions (which are an integral part IE) 

 

Update Internet Explorer (Go to Windows Update) 
Make sure you have updated IE with all the latest patches & service packs from Microsoft. Go to "Windows 

Update" and download and install the latest IE Service Pack.  
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Top Security Tips (Best Practices) 
   

1. Periodically check that your database is properly protected against 
unauthorized access.  
If you installed PDshop with the default Microsoft Access database, make sure it is impossible for someone 

(other than you) to download/access your database file. Your database directory should be configured with 

special permissions (a.k.a. Security) in such a way that PDshop & PDAdmin can read/write to the 

database, but no one else can see or download it. We recommend that your database be kept in a special 

directory that is only accessible by FTP. Consult with your web host or server administrator for their 

procedures and suggestions for securing database directories.  

 

IMPORTANT: We strongly recommend that you rename your database file.  You should use a unique name 

that only you would know.  For example, do not leave your database with a name like "PDshop.mdb".  You 

will need to update your setup.asp (or web.config) file accordingly.   

 

2. Rename your "admin" and "data" directories to help protect against 
unauthorized access.  
Since these directory names are common knowledge, as an added level of security we suggest that you 

rename these directories to something only you would know.  You will need to update your setup.asp (or 

web.config) file accordingly.   

 

3. Change your passwords often, and do not use the same username/password 
combinations more than once.  
Change your password at regular intervals and make sure your PDAdmin username/password is not the 

same as your FTP, hosting account, or server control panel logins. This can be devastating if your 

password is ever found or discovered thru some of the various hacking techniques.  

 

4. Make sure your web host/server admin has properly protected your web 
server.  
A web server with poor firewall protection, or insufficient settings, or an "unpatched" operating system, 

can make your website vulnerable to many internet threats, including unauthorized access, malicious 

attacks, and virus infection.  

 

5. Download and Install the latest revision of PDshop periodically.  
Our developers are always improving how PDshop works, for this reason revisions to each edition of 

PDshop are released from time to time. These revisions/updates are full versions that often contain 

improvements, bug fixes, critical security updates, and even new features. To download the latest 

revision, login to your account and click 'Your Downloads'. See the Upgrading & Installation Guides for 

help with installation or upgrading procedures.  If you need assistance with installing these 

revisions/updates, contact PageDown Technology. NOTE: If you are using a customized version of PDshop 

or made your own script changes, consult with your web developer or PageDown Tech. before installing 

any revisions. 

 

6. Enable all 'Recommended Security Settings' in PDAdmin. 
Since you may be hosting PDshop on a public or shared web server, as a general precaution, we do not 

recommend storing sensitive credit card information in your PDshop database.  If you are processing 
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credit cards, you should do so thru one of the payment gateways that PDshop supports.  When processing 

thru the supported payment gateways, PDshop does not need to store any credit card information; it is 

securely passed to the payment gateway's own system for processing.  Storing credit card data on your 

own web site can put your customer's information at higher risk.  See PDAdmin 'Help' for more 

information on these settings. 

 

7. Download and Install PDScan 

(All PDshop editions downloaded after 11/15/06 include PDScan built-in, so installation is not required if you 
downloaded PDshop after 11/15/06) 

PDScan is a free add-on for all ASP editions of PDshop. PDScan is a simple HTTP request scanner that can 

easily be "included" into any edition of PDshop. The purpose of this Add-On is to provide an extra layer of 

security & protection. PDScan filters all incoming http requests, such as URLs & Querystrings, Forms, and 

Cookies. If it detects malicious or erroneous data in an http request, the request will be rejected; it may 

be able to protect your website from future or unknown internet threats and exploits.  If you have 

customized your copy of PDshop, you can still install PDScan by simply "including" it into your setup.asp 

file. 

 

Special Notes   

If your copy of PDshop was installed by a 3rd party, or by PageDown Technology, you may need to 

contact the person or company who handled your installation, or order the "Installation Service" from 

PageDown Technology.  To order our Installation Service, please login to your account.  Click "My 

Account" from anywhere on the PageDown Technology website. 
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Terms & Conditions 
 

This guide is intended for licensed users of PDshop only.   

 

See the Terms & Conditions for PDshop on the PageDown Technology website, see 

http://www.pagedowntech.com/terms. 

 

Additional Support and Information about this product can be found on PageDown Technology’s website, 

http://www.pagedowntech.com. 

 

Copyright Notice:  

All Text and Images contained on this document is the property of PageDown Technology, LLC 

(pagedowntech.com) and cannot be reproduced, copied, or used without our written permission.   

 

PageDown Technology, LLC / Copyright 2003-2008 All Rights Reserved   

 


